Help running cli

I have downloaded the github templates project repo and would like to run the cli in order to practice the entity creation task in the data loading module. I have tried running the script under cli folder but ended up with the following error. Could you help me debug this.

Also, could you confir where to find the config variables: token,client and project id field? I have tried checking settings/project settings/properties.

1 Like

Hi Filsan,

We’re pleased to hear from you again and to see that you have progressed past your last issue. The two issues you have presented in this post are related.

Running the command requires the three variables that you have mentioned to be passed as arguments. A basic version of what this command can be:

python --cluster $CLUSTER --project-id $PROJECT_ID --token $TOKEN

Please see the script in the same directory as to see a more detailed version of this command.

For the three config variables, it sounds like you have a Squirro Instance running. If I have assumed correctly, then you can find those here:

cluster: This is the base url where your Squirro Instance is deployed. For example:

project_id: This is found in the location you have mentioned, “Settings > Project Settings > Properties”. Below is a screenshot of where you should be finding this field.

token: This is found in your User Profile. You can begin to access this by clicking on your avatar with your initials in the top right (screenshot below).

  • From here navigate to: “My Account > API Access”

  • You should arrive at a page with list of different access tokens, which may appear blank upon your first visit.

  • Go to the first token, named “User Token”, and hit the “Renew” button immediately below the field. The token should then become visible to you.

Please set these variables within your script. Alternatively, you can input these directly on the command line as shown above.

I hope this helps and lets you continue on your way!
Best regards,

Hubert Shon

1 Like

thank you for the response. I am now trying to run the data_loader/1_csv/ script. I have set my config variables but get the following error about ‘bind’ not being set. Any ideas on how i can fix this?

Hi Filsan,

My guess from that error message is that an incorrect version of a Squirro dependency was installed. Could you please run the following command and see if that resolves the error your seeing?

pip install "sqlalchemy==1.3.13"