Pipelet config error

I am trying to input the config as shown in the pipelet tutorial but keep getting an error?

also get a token error

Hi filsan.hassan,
Thanks for reaching out to us. Is it possible for you to share the link to which pipelet tutorial you are following?

In regards to the config error, can you confirm that you have self.match_in_title = self.config.get("match_in_title") present in the pipelets __init__ and that getArguments() looks like this:

def getArguments():
    return [
            "name": "match_in_title",
            "display_label": "Match date in title",
            "type": "bool",
            "default": False,

If this is as expected, it may be easier to diagnose this if you could share the code of company_size.py with us.


@aaron.pedersen thanks I am getting the token error above first. I have tried refreshing the token but still same error

Hi @filsan.hassan,
Which tutorial are you following? It would also be helpful to know when this 404 is being thrown. Is it during pipelet upload? If so, sharing the command you are using and the output of

pipelet -vvvv upload --token <your_token> --cluster <cluster> <your_pipelet>.py "<Pipelet Title>"

It would help diagnose the issue.


1 Like

thanks i was missing a ‘-’ it has worked now! and i was referring to the pipeletes tutorial in the squiro engineering academy and have found the answer in a previous post. thanks